use strict;
my $str = 'T441_S45/1
007_S4
41_445T02_74
';
my $regex = qr/^[^\n\d]*(\d+)(?:[^\n\d]+(\d+))?(?:[^\n\d]+(\d+))?.*/mp;
my $subst = '$1 $2 $3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";