import Foundation
let pattern = #"^[^\n\d]*(\d+)(?:[^\n\d]+(\d+))?(?:[^\n\d]+(\d+))?.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
T441_S45/1
007_S4
41_445T02_74
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2 $3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)