re = /^[^\n\d]*(\d+)(?:[^\n\d]+(\d+))?(?:[^\n\d]+(\d+))?.*/m
str = 'T441_S45/1
007_S4
41_445T02_74
'
subst = '$1 $2 $3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result