using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^]]*]$";
string input = @"[find the l/ast dot . in this . ridden text . . . []re/ally]/]
asjdakjsgdakjsgdajsgdajsgdjkagdajksgdk]ajsgd/
sdjkhasda8dy98asyd98adhahda8shd98h28h98]2h98h429h8329h8398hrwrh8ewer/
ALKSJlkajsLKASJ[IMG:232442323.JPG@SOMEDOMAIN.COM]itdoesntmattter
whatorhowitritethisstring]
* the fat cat in the purple hat
* needs to go on a diet or it will break the machine
*** which will absolutely cause some insurance cost increases]]
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}