import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^]]*]$";
final String string = "[find the l/ast dot . in this . ridden text . . . []re/ally]/]\n"
+ "asjdakjsgdakjsgdajsgdajsgdjkagdajksgdk]ajsgd/\n"
+ "sdjkhasda8dy98asyd98adhahda8shd98h28h98]2h98h429h8329h8398hrwrh8ewer/\n"
+ "ALKSJlkajsLKASJ[IMG:232442323.JPG@SOMEDOMAIN.COM]itdoesntmattter\n"
+ "whatorhowitritethisstring]\n"
+ "* the fat cat in the purple hat \n"
+ "* needs to go on a diet or it will break the machine\n"
+ "*** which will absolutely cause some insurance cost increases]]\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}