// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^]]*]$").unwrap();
let string = "[find the l/ast dot . in this . ridden text . . . []re/ally]/]
asjdakjsgdakjsgdajsgdajsgdjkagdajksgdk]ajsgd/
sdjkhasda8dy98asyd98adhahda8shd98h28h98]2h98h429h8329h8398hrwrh8ewer/
ALKSJlkajsLKASJ[IMG:232442323.JPG@SOMEDOMAIN.COM]itdoesntmattter
whatorhowitritethisstring]
* the fat cat in the purple hat
* needs to go on a diet or it will break the machine
*** which will absolutely cause some insurance cost increases]]
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}