re = /[^]]*]$/
str = '[find the l/ast dot . in this . ridden text . . . []re/ally]/]
asjdakjsgdakjsgdajsgdajsgdjkagdajksgdk]ajsgd/
sdjkhasda8dy98asyd98adhahda8shd98h28h98]2h98h429h8329h8398hrwrh8ewer/
ALKSJlkajsLKASJ[IMG:232442323.JPG@SOMEDOMAIN.COM]itdoesntmattter
whatorhowitritethisstring]
* the fat cat in the purple hat
* needs to go on a diet or it will break the machine
*** which will absolutely cause some insurance cost increases]]
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end