const regex = new RegExp('[^]]*]$', '')
const str = `[find the l/ast dot . in this . ridden text . . . []re/ally]/]
asjdakjsgdakjsgdajsgdajsgdjkagdajksgdk]ajsgd/
sdjkhasda8dy98asyd98adhahda8shd98h28h98]2h98h429h8329h8398hrwrh8ewer/
ALKSJlkajsLKASJ[IMG:232442323.JPG@SOMEDOMAIN.COM]itdoesntmattter
whatorhowitritethisstring]
* the fat cat in the purple hat
* needs to go on a diet or it will break the machine
*** which will absolutely cause some insurance cost increases]]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}