import Foundation
let pattern = #"[^]]*]$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[find the l/ast dot . in this . ridden text . . . []re/ally]/]
asjdakjsgdakjsgdajsgdajsgdjkagdajksgdk]ajsgd/
sdjkhasda8dy98asyd98adhahda8shd98h28h98]2h98h429h8329h8398hrwrh8ewer/
ALKSJlkajsLKASJ[IMG:232442323.JPG@SOMEDOMAIN.COM]itdoesntmattter
whatorhowitritethisstring]
* the fat cat in the purple hat
* needs to go on a diet or it will break the machine
*** which will absolutely cause some insurance cost increases]]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}