# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^]]*]$"
test_str = ("[find the l/ast dot . in this . ridden text . . . []re/ally]/]\n"
"asjdakjsgdakjsgdajsgdajsgdjkagdajksgdk]ajsgd/\n"
"sdjkhasda8dy98asyd98adhahda8shd98h28h98]2h98h429h8329h8398hrwrh8ewer/\n"
"ALKSJlkajsLKASJ[IMG:232442323.JPG@SOMEDOMAIN.COM]itdoesntmattter\n"
"whatorhowitritethisstring]\n"
"* the fat cat in the purple hat \n"
"* needs to go on a diet or it will break the machine\n"
"*** which will absolutely cause some insurance cost increases]]\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.