#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.+?)\."
Local $sString = "Dog.Jumping.png" & @CRLF & _
"Horse.Jumping.gif" & @CRLF & _
"Cat.Jumping.jpg" & @CRLF & _
"Lion.Jumping.tiff" & @CRLF & _
"Shark.Jumping.svg" & @CRLF & _
"Cow.Jumping.psd"
Local $sSubst = "$1 - "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)