const regex = /^(.+?)\./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.+?)\\.', 'gm')
const str = `Dog.Jumping.png
Horse.Jumping.gif
Cat.Jumping.jpg
Lion.Jumping.tiff
Shark.Jumping.svg
Cow.Jumping.psd`;
const subst = `$1 - `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);