use strict;
my $str = 'Dog.Jumping.png
Horse.Jumping.gif
Cat.Jumping.jpg
Lion.Jumping.tiff
Shark.Jumping.svg
Cow.Jumping.psd';
my $regex = qr/^(.+?)\./mp;
my $subst = '$1 - ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";