using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+?)\.";
string substitution = @"$1 - ";
string input = @"Dog.Jumping.png
Horse.Jumping.gif
Cat.Jumping.jpg
Lion.Jumping.tiff
Shark.Jumping.svg
Cow.Jumping.psd";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}