package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.+?)\.`)
var str = `Dog.Jumping.png
Horse.Jumping.gif
Cat.Jumping.jpg
Lion.Jumping.tiff
Shark.Jumping.svg
Cow.Jumping.psd`
var substitution = "$1 - "
fmt.Println(re.ReplaceAllString(str, substitution))
}