import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.+?)\\.";
final String string = "Dog.Jumping.png\n"
+ "Horse.Jumping.gif\n"
+ "Cat.Jumping.jpg\n"
+ "Lion.Jumping.tiff\n"
+ "Shark.Jumping.svg\n"
+ "Cow.Jumping.psd";
final String subst = "$1 - ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}