$re = '/^(.+?)\./m';
$str = 'Dog.Jumping.png
Horse.Jumping.gif
Cat.Jumping.jpg
Lion.Jumping.tiff
Shark.Jumping.svg
Cow.Jumping.psd';
$subst = "$1 - ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;