# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<br(?: \/)?>\K\s+//gi;t' <<< "This is a space after a <br> break.
This is 2 spaces after a <br> break.
This is a tab after a <br> break.
This is a newline after a <br>
break;"