import re
regex = re.compile(r"<br(?: /)?>\K\s+", flags=re.IGNORECASE)
test_str = ("This is a space after a <br> break.\n"
"This is 2 spaces after a <br> break.\n"
"This is a tab after a <br> break.\n"
"This is a newline after a <br>\n"
"break;")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)