use strict;
my $str = 'This is a space after a <br> break.
This is 2 spaces after a <br> break.
This is a tab after a <br> break.
This is a newline after a <br>
break;';
my $regex = qr~<br(?: /)?>\K\s+~ip;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";