re = /<br(?: \/)?>\K\s+/i
str = 'This is a space after a <br> break.
This is 2 spaces after a <br> break.
This is a tab after a <br> break.
This is a newline after a <br>
break;'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result