import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<br(?: /)?>\\K\\s+";
final String string = "This is a space after a <br> break.\n"
+ "This is 2 spaces after a <br> break.\n"
+ "This is a tab after a <br> break.\n"
+ "This is a newline after a <br>\n"
+ "break;";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}