# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\b(?:DR|prof)\.[^\S\n]+)+|[^\w\s]+//gm;t' <<< "DR. Tida.
prof. Sina.
DR. prof. Tida."