package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\b(?:DR|prof)\.[^\S\n]+)+|[^\w\s]+`)
var str = `DR. Tida.
prof. Sina.
DR. prof. Tida.`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}