import Foundation
let pattern = #"(?:\b(?:DR|prof)\.[^\S\n]+)+|[^\w\s]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
DR. Tida.
prof. Sina.
DR. prof. Tida.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)