use strict;
my $str = 'DR. Tida.
prof. Sina.
DR. prof. Tida.';
my $regex = qr/(?:\b(?:DR|prof)\.[^\S\n]+)+|[^\w\s]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";