using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\b(?:DR|prof)\.[^\S\n]+)+|[^\w\s]+";
string substitution = @"";
string input = @"DR. Tida.
prof. Sina.
DR. prof. Tida.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}