$re = '/(?:\b(?:DR|prof)\.[^\S\n]+)+|[^\w\s]+/m';
$str = 'DR. Tida.
prof. Sina.
DR. prof. Tida.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;