#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\b(?:DR|prof)\.[^\S\n]+)+|[^\w\s]+"
Local $sString = "DR. Tida." & @CRLF & _
"prof. Sina." & @CRLF & _
"DR. prof. Tida."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)