package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\S\s]*?)([0-9]+|OVA|Any|Thing|Else|That|Like)`)
var str = `Hunter x Hunter OVA 08 = OVA 08
Hunter x Hunter OVA Greed Island Final 01 = OVA Island 01
Hunter x Hunter VOA Greed Island Final 01 = OVA Island 01
Hunter O Hunter VOA Greed Island Final 01 = OVA Island 01
Hunter x Hunter 02 = 02`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}