import re
regex = re.compile(r"([\S\s]*?)([0-9]+|OVA|Any|Thing|Else|That|Like)", flags=re.MULTILINE)
test_str = ("Hunter x Hunter OVA 08 = OVA 08\n"
"Hunter x Hunter OVA Greed Island Final 01 = OVA Island 01\n"
"Hunter x Hunter VOA Greed Island Final 01 = OVA Island 01\n"
"Hunter O Hunter VOA Greed Island Final 01 = OVA Island 01\n"
"Hunter x Hunter 02 = 02")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")