// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([\S\s]*?)([0-9]+|OVA|Any|Thing|Else|That|Like)").unwrap();
let string = "Hunter x Hunter OVA 08 = OVA 08
Hunter x Hunter OVA Greed Island Final 01 = OVA Island 01
Hunter x Hunter VOA Greed Island Final 01 = OVA Island 01
Hunter O Hunter VOA Greed Island Final 01 = OVA Island 01
Hunter x Hunter 02 = 02";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}