import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\S\\s]*?)([0-9]+|OVA|Any|Thing|Else|That|Like)";
final String string = "Hunter x Hunter OVA 08 = OVA 08\n"
+ "Hunter x Hunter OVA Greed Island Final 01 = OVA Island 01\n"
+ "Hunter x Hunter VOA Greed Island Final 01 = OVA Island 01\n"
+ "Hunter O Hunter VOA Greed Island Final 01 = OVA Island 01\n"
+ "Hunter x Hunter 02 = 02";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}