#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?si)<a\s.*?['"]\s*>((?:(?!<\/a>).)*)<\/a>"
Local $sString = "<a href="https://google.com"" & @CRLF & _
"title="some title"" & @CRLF & _
"data-key="{'key':'adf0a8dfq<>*1$4%' >" & @CRLF & _
"" & @CRLF & _
"some context in here <>" & @CRLF & _
"" & @CRLF & _
"some context in there <>" & @CRLF & _
"" & @CRLF & _
"</a>" & @CRLF & _
"" & @CRLF & _
"<A href="https://google.com"" & @CRLF & _
"title="some title"" & @CRLF & _
"data-key="{'key':'adf0a8dfq<>*1$4%'>" & @CRLF & _
"" & @CRLF & _
"some context in here" & @CRLF & _
"" & @CRLF & _
"some context in there" & @CRLF & _
"" & @CRLF & _
"</A>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")