import re
regex = re.compile(r"<a\s.*?['\"]\s*>((?:(?!<\/a>).)*)<\/a>", flags=re.DOTALL | re.IGNORECASE)
test_str = ("<a href=\"https://google.com\"\n"
"title=\"some title\"\n"
"data-key=\"{'key':'adf0a8dfq<>*1$4%' >\n\n"
"some context in here <>\n\n"
"some context in there <>\n\n"
"</a>\n\n"
"<A href=\"https://google.com\"\n"
"title=\"some title\"\n"
"data-key=\"{'key':'adf0a8dfq<>*1$4%'>\n\n"
"some context in here\n\n"
"some context in there\n\n"
"</A>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")