using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a\s.*?['""]\s*>((?:(?!<\/a>).)*)<\/a>";
string input = @"<a href=""https://google.com""
title=""some title""
data-key=""{'key':'adf0a8dfq<>*1$4%' >
some context in here <>
some context in there <>
</a>
<A href=""https://google.com""
title=""some title""
data-key=""{'key':'adf0a8dfq<>*1$4%'>
some context in here
some context in there
</A>";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}