import Foundation
let pattern = #"<a\s.*?['"]\s*>((?:(?!<\/a>).)*)<\/a>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
<a href="https://google.com"
title="some title"
data-key="{'key':'adf0a8dfq<>*1$4%' >
some context in here <>
some context in there <>
</a>
<A href="https://google.com"
title="some title"
data-key="{'key':'adf0a8dfq<>*1$4%'>
some context in here
some context in there
</A>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)