$re = '/<a\s.*?[\'"]\s*>((?:(?!<\/a>).)*)<\/a>/si';
$str = '<a href="https://google.com"
title="some title"
data-key="{\'key\':\'adf0a8dfq<>*1$4%\' >
some context in here <>
some context in there <>
</a>
<A href="https://google.com"
title="some title"
data-key="{\'key\':\'adf0a8dfq<>*1$4%\'>
some context in here
some context in there
</A>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);