import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a\\s.*?['\"]\\s*>((?:(?!<\\/a>).)*)<\\/a>";
final String string = "<a href=\"https://google.com\"\n"
+ "title=\"some title\"\n"
+ "data-key=\"{'key':'adf0a8dfq<>*1$4%' >\n\n"
+ "some context in here <>\n\n"
+ "some context in there <>\n\n"
+ "</a>\n\n"
+ "<A href=\"https://google.com\"\n"
+ "title=\"some title\"\n"
+ "data-key=\"{'key':'adf0a8dfq<>*1$4%'>\n\n"
+ "some context in here\n\n"
+ "some context in there\n\n"
+ "</A>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}