const regex = /<a\s.*?['"]\s*>((?:(?!<\/a>).)*)<\/a>/gsi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a\\s.*?[\'"]\\s*>((?:(?!<\\\/a>).)*)<\\\/a>', 'gsi')
const str = `<a href="https://google.com"
title="some title"
data-key="{'key':'adf0a8dfq<>*1\$4%' >
some context in here <>
some context in there <>
</a>
<A href="https://google.com"
title="some title"
data-key="{'key':'adf0a8dfq<>*1\$4%'>
some context in here
some context in there
</A>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}