#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\buse (?:(?<name>\w+)\.)*(?<name>\w+);"
Local $sString = "-------------------------------------------------------------------------------" & @CRLF & _
"library ieee;" & @CRLF & _
"use ieee.std_logic_1164.all;" & @CRLF & _
"use ieee.numeric_std.all;" & @CRLF & _
"" & @CRLF & _
"use work.pk_avalon_mm_extif_defs.all;" & @CRLF & _
"use work.common_tb_pkg.all;" & @CRLF & _
"" & @CRLF & _
"package common_register_interface_pkg is" & @CRLF & _
"" & @CRLF & _
"127.0.0.1.2.3.4" & @CRLF & _
"" & @CRLF & _
"use ieee.std_logic_1164.b.c.d.all;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")