import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\buse (?:(?<name>\\w+)\\.)*(?<name>\\w+);";
final String string = "-------------------------------------------------------------------------------\n"
+ "library ieee;\n"
+ "use ieee.std_logic_1164.all;\n"
+ "use ieee.numeric_std.all;\n\n"
+ "use work.pk_avalon_mm_extif_defs.all;\n"
+ "use work.common_tb_pkg.all;\n\n"
+ "package common_register_interface_pkg is\n\n"
+ "127.0.0.1.2.3.4\n\n"
+ "use ieee.std_logic_1164.b.c.d.all;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}