// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\buse (?:(?<name>\w+)\.)*(?<name>\w+);").unwrap();
let string = "-------------------------------------------------------------------------------
library ieee;
use ieee.std_logic_1164.all;
use ieee.numeric_std.all;
use work.pk_avalon_mm_extif_defs.all;
use work.common_tb_pkg.all;
package common_register_interface_pkg is
127.0.0.1.2.3.4
use ieee.std_logic_1164.b.c.d.all;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}