package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\buse (?:(?<name>\w+)\.)*(?<name>\w+);`)
var str = `-------------------------------------------------------------------------------
library ieee;
use ieee.std_logic_1164.all;
use ieee.numeric_std.all;
use work.pk_avalon_mm_extif_defs.all;
use work.common_tb_pkg.all;
package common_register_interface_pkg is
127.0.0.1.2.3.4
use ieee.std_logic_1164.b.c.d.all;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}