import re
regex = re.compile(r"\buse (?:(?<name>\w+)\.)*(?<name>\w+);", flags=re.MULTILINE)
test_str = ("-------------------------------------------------------------------------------\n"
"library ieee;\n"
"use ieee.std_logic_1164.all;\n"
"use ieee.numeric_std.all;\n\n"
"use work.pk_avalon_mm_extif_defs.all;\n"
"use work.common_tb_pkg.all;\n\n"
"package common_register_interface_pkg is\n\n"
"127.0.0.1.2.3.4\n\n"
"use ieee.std_logic_1164.b.c.d.all;")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")