using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\buse (?:(?<name>\w+)\.)*(?<name>\w+);";
string input = @"-------------------------------------------------------------------------------
library ieee;
use ieee.std_logic_1164.all;
use ieee.numeric_std.all;
use work.pk_avalon_mm_extif_defs.all;
use work.common_tb_pkg.all;
package common_register_interface_pkg is
127.0.0.1.2.3.4
use ieee.std_logic_1164.b.c.d.all;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}