re = /\buse (?:(?<name>\w+)\.)*(?<name>\w+);/m
str = '-------------------------------------------------------------------------------
library ieee;
use ieee.std_logic_1164.all;
use ieee.numeric_std.all;
use work.pk_avalon_mm_extif_defs.all;
use work.common_tb_pkg.all;
package common_register_interface_pkg is
127.0.0.1.2.3.4
use ieee.std_logic_1164.b.c.d.all;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end