#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(\b[SMLX]+\b)|(Univerzální)|(\d+\s*-\s*\d+\s*let)"
Local $sString = "Dámské mikinošaty bez potisku - Černá M - volný střih" & @CRLF & _
"Dámské mikinošaty bez potisku - Černá XS - volný střih" & @CRLF & _
"Taška Happy Nature Příroda - Černá Univerzální" & @CRLF & _
"Čepice Západ - Šedá Univerzální" & @CRLF & _
"Dětská mikina bez kapuce Never stop dreaming - Karmínově růžová 9 - 11 let" & @CRLF & _
"Dámské tričko Štěstí - Hořčicová - okrově žlutá L"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")