$re = '/(\b[SMLX]+\b)|(Univerzální)|(\d+\s*-\s*\d+\s*let)/mi';
$str = 'Dámské mikinošaty bez potisku - Černá M - volný střih
Dámské mikinošaty bez potisku - Černá XS - volný střih
Taška Happy Nature Příroda - Černá Univerzální
Čepice Západ - Šedá Univerzální
Dětská mikina bez kapuce Never stop dreaming - Karmínově růžová 9 - 11 let
Dámské tričko Štěstí - Hořčicová - okrově žlutá L';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);