using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b[SMLX]+\b)|(Univerzální)|(\d+\s*-\s*\d+\s*let)";
string input = @"Dámské mikinošaty bez potisku - Černá M - volný střih
Dámské mikinošaty bez potisku - Černá XS - volný střih
Taška Happy Nature Příroda - Černá Univerzální
Čepice Západ - Šedá Univerzální
Dětská mikina bez kapuce Never stop dreaming - Karmínově růžová 9 - 11 let
Dámské tričko Štěstí - Hořčicová - okrově žlutá L";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}